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Overview

The SCCM plug-in sends inventory information from the JSS to the JSS SCCM Proxy Service, and then to
Microsoft’s System Center Configuration Manager (SCCM). It uses the JSS Events API to ensure that SCCM
always has the most up-to-date hardware and software information for the computers and mobile devices
in your JSS.

Requirements

Installing and configuring the SCCM plug-in requires:
= Microsoft’s System Center Configuration Manager (SCCM) 2012
= The Casper Suite or Recon Suite v8.6 running in your environment
= A JSS user account with the following API privileges:
+ Read Computers
+  Read Mobile Devices

For instructions on granting API privileges to JSS user accounts, see the “Managing JSS User Accounts”
section of the Casper Suite Administrator’s Guide.

Generating an ISV proxy certificate requires:

= AWindows computer with the Certification Authority snap-in

= A public key infrastructure (PKI) that does not use the CA that is built into the JSS
= Console access to the SCCM server

= Administrative rights to the SCCM Console

Setting up the JSS SCCM Proxy Service requires a Windows computer with Microsoft .NET Framework 4.



Generating an ISV Proxy Certificate

Step 1: Create a Certificate Template

On a Windows computer with the Certification Authority snap-in, open the Certification Authority.

In the Certification Authority tool, expand the certificate authority in the sidebar.

Right-click Certificate Templates in the sidebar and select Manage.

[ certsrv - [Certification Authority (Local)\JAMF Software Certificate Authority\Certificate Templates]

Fle Acton View Help

e 5|a=H

i Certfication Authority (Local)

El @i JAMF Software Certificate Authority
7| Revoked Certificates
-] Tssued Certificates
| Pending Requests

In the Template Manager window, right-click the Computer template and select Duplicate Template.

In the Duplicate Template dialog that appears, select the Windows Server 2003 Enterprise option, and

then click OK.

Intended Purpose

2] ConfigMar 2012 Clent 0P Cert

E ConfigMgr Mac Client Certificate
E MP Proxy Certificate

3] 5CaM2012 Web Server Cert

3 cross Certification Autharity

3l amFuser

3 JAMF Computer

3l scM web Server

]| Config Mgr Site Signing Cerfificate
3] P Encryption

)] Exchange Enroliment Agent (Offiine req. ..
3 Psec (Offine request)

3] Drrectory Email Repécation

3 Domain Controlier Authentication
2] EFS Recovery Agent

3] Basic EFS

3 Domain Controlier

3] web server

EI Computer

E User

] subordinate Certification Authority
3] admnistrater

Chent Authentication

Clent Authentication

Server Authentication, Client Authentication

Server Authentication

<All>

Chient Authentication, Secure Emai, Enary. .,

Server Authentication, Client Authentication

Server Authentication

Document Signing

Certificate Request Agent

Certificate Request Agent

IP security IKE intermediate

Directory Service Email Replication

Client Authentication, Server Authenticatio...
File Recovery

Encrypting File System

Client Authentication, Server Authentication

Server Authentication

Client Authentication, Server Authentication

Encrypting Fle System, Secure Email, Clen...
<All>

Micrasoft Trust List Signing, Encrypting File...

Duplicate Template B

‘fou can create certificate templates with advanced properties. However,
not all Windows CAs support all certificate template properties.Select the
wversion of Windows Server (minimum supported CAs) for the duplicate

certificate templats,

¥ Windows Server 2003 Enterprise

" Windows Server 2008 Enterprise

Learn more about Cerfificate Template Vergions.
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6. On the General tab, enter a display name for the template, and select the Publish certificate in Active
Directory checkbox.

Properties of New Template E

" lssuance Requremerts | Superseded Templates | Bdensions | Securty |
Genesl | RequestManding | SubjectName |  Server

Template dsplay name:
|55 SCCM Proxy Certfiicate

Minimum Supported CAs: Windows Server 2003 Enterprize

Template name:
|IS5SCCMProwyCertficate

Validity period: Renewal period:
s N

V¥ Publish cenficate in Active Dirsctory

[T Do not automaticaly reenmoll f a duplicate certficate exists in Active
Directory

r For automatic renewal of smart cand certificates, use the existing key
if @ new key cannot be created

7. Onthe Subject Name tab, choose "Common name" from the Subject name format pop-up menu.

8. On the Security tab, ensure that the user that you plan to use to generate the ISV proxy certificate has read
and enroll permissions, and then click OK.

" Genel | RequestHanding | SubectName | Server |
Issuance Requrements | Superseded Templates | Exensons  Security
Group or user names:

52 Athenticated Users
& Administrator (administrator@ad jamfzw com)

A Domain Admins (AD\Demain Adming

.33, Domain Computers (AD"Domain Computers)
82 Enterprise Admins (AD'\Enterprise Admins)

Add.. | Remaove |
Pemissions for Domain Admins Alow Deny
Full Control O a
Read a
Write |
Enrol a
PAutoenrol a a

For special pemissions or advanced settings. click. Advanced I
Advanced.

9. Close the Template Manager window.



10.

11.

4.

5.

In the Certification Authority tool, right-click Certificate Templates in the sidebar, and select New >

Certificate Template to Issue.

[ certsrv - [Certification Authority (Local)\JAMF Software Certificate Authority\Certificate Templates]

File Acton View Help

e |7 c=H

Ll Certfication Authority (Local)

~| Revoked Certificates
7| Issued Certificates
| Pending Requests

=l g JAMF Software Certificate Authority

Name

Immn_.-E

| 2] ConfigMor 2012 Client DP Cert
7| ConfigMgr Mac Client Certificate
3] MP Proxy Certificate
3] scoM2012 Web Server Cert
3] cross Certification Authority
3] 3AMFUser
3 JAMF Computer
3 5CCM Web Server
3] config Mgr Site Signing Certificate
3] cep Enaryption

3 psec (Offiine request)

3] Directory Email Repication

2] Domain Cantroller Authentication
3] £75 Recovery Agent

] BasicEFs.

3 Bomain Controller

3] Web server

EI Computer

3] user

3 subordinate Certification Autharity
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)] Exchange Enroliment Agent (Offine req. ..

Client Authentication

Client Authentication

Server Authentication, Client Authentication

Server Authentication

<All>

Clent Authentication, Secure Email, Encry...

Server Authentication, Client Authentication

Server Authentication

Document Signing

Certificate Request Agent

Certificate Request Agent

[P security IKE intermediate

Directory Service Email Replcation

Client Authentication, Server Authenticatio. ..
Fle Recovery

Encrypting File System

Client Authentication, Server Authentication

Server Authentication

Client Authentication, Server Authentication

Encrypting File System, Secure Email, Clien...
<All>

Microsoft Trust List Signing, Enarypting File...

Choose the template you just created and click OK.

Step 2: Generate an ISV Proxy Certificate from the Template

On the Windows computer on which you plan to install the JSS SCCM Proxy Service, open Microsoft

Management Console (MMC).

From the menu bar, choose File > Add/Remove Snap-in.

Select Certificates in the list of snap-ins and click the Add button.

x|

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ns, you can configure which extensions are enabled.

Available snap-ins: Selected snap-ns:
Snap-n ‘ Vendor ‘ = [ Console Root
=" ActiveX Control Microsoft Cor...

Authorlzatlon Manager Microsoft Cor...
Certificates Microsoft Cor...

. Component Services  Microsoft Cor...

*‘Cumpuher Managem... Microsoft Cor... =

éDevice Manager Microsoft Cor...

=4 Disk Management Microsoft and... Add >

@ Event Viewer Microsoft Cor...

"I Folder Microsoft Cor...

_E,J' Group Policy Object ... Microsoft Cor...

t. Internet Information... Microsoft Cor...

(internet Information... Microsoft Cor...

.g IP Security Monitor Microsoft Cor...

B, 1p Securitv Policy Ma.... Microsoft Cor... ﬂ

Description:

Edit Extensions. .. |
Remave |

Mave lp |
[Mave Do |

Advanced... |

The Certificates snap-in allows you to browse the contents of the certificate stores for yourself, a service, or a computer.

Select the Computer account option and click Next.

Select the Local computer (the computer this console is running on) option.



10.

11.

Click Finish, and then click OK.
The certificate is displayed below the Console Root folder in the sidebar.

Expand "Certificates (Local Computer)" in the sidebar.

Right-click the Personal folder in the sidebar under "Certificates (Local Computer)", and select
All Tasks > Request New Certificate.

Follow the onscreen instructions, and then select the checkbox next to the template you just created.
Then, click Enroll.

B Certificate Enrollment 10l x|

|5 Certificate Enroliment

Request Certificates

You can request the following types of certificates. Select the certificates you want to request, and then dick Enroll.

-
["ConfigMgr 2012 Client DP Cert 1 STATUS: Available Detals(®

[~ JAMF Computer 1) STATUS: Available Detallsi®)
ﬁ Mare information is required to enroll for this certificate. Click here to configure settings.

[¥355 SCCM Proxy Certificate 1 STATUS: Available Detals(®

™ Show all templates

Learn more about certificates

Note: If the template you just created is not listed, verify that the user you are using to generate the ISV
proxy certificate has the appropriate permissions.

The newly created certificate should appear in the list of certificates.

7 Console1 - [Console Root\Certificates (Local Computer)\Personal\Certificates] - |EI ll
[@ Fle Acton View Favorites Window Help |_5||5|

les 2=l §6ERE = HE

] Console Root Issued To = [ 1ssued By | Expiration Date
El [ Certificates (Local Computer) Ems_scm_mcxv.ad.jmfm.m JAMF Software Certificate Authority  9/21/2013

= [ Personal Fol WMSvC-WIN-BMOVLTORG27 WMSvc-WIN-BMOVLTORG27 5/18/2022
| Certificates

[ Trusted Root Certification Aul

= Enterprise Trust 155_SCCM_PROXY.adj...

[ Intermediate Certification Aut More Actions »

[ Trusted Publishers

[ Untrusted Certificates

(| Third-Party Root Certification

[ Trusted People

[ Certificate Enrollment Reques

[ Smart Card Trusted Roots

[ Trusted Devices

More Actions 4

Double-click the newly created certificate.

In the dialog that appears, click the Details tab, and then click Edit Properties.




12.  Enter a friendly name for the newly created certificate and click OK.
It is recommended that you use "JSS SCCM Proxy Certificate" for the friendly name.
21|

General | Cross-Certificates | OCSP | Extended Validation |

Friendly name:

Description: I

- Certificate purposes
' Enable all purposes for this certificate
" Disable all purposes for this certificate
" Enable only the following purposes

Mote: You may only edit certificate purposes that are allowed by
the certification path.

Server Authentication
Client Authentication

1 | Bl

Add Purpose, .. |

Learn more about certificate properties

0K I Cancel Apply

13. Click OK again.
14. Right-click the certificate and select All Tasks > Export.

15. Follow the onscreen instructions to export the certificate as a DER-encoded .cer file.

Step 3: Copy the ISV Proxy Certificate to the SCCM Server

If you do not plan to install the JSS SCCM Proxy Service on the SCCM server, copy the ISV proxy certificate (.cer)
to the SCCM server. If the JSS SCCM Proxy Service will be installed on the SCCM Server, skip to “Step 4: Register
the ISV Proxy Certificate with SCCM".

Step 4: Register the ISV Proxy Certificate with SCCM

1. Onthe SCCM server, open SCCM and click the Administration category in the sidebar.

2. Click the disclosure triangle next to the Security folder in the sidebar.



3. Right-click Certificates and select Register or Renew ISV Proxy.

& System Center 2012 Configuration Manager (Connected to TST - JAMF SCCM2012 Test) (Evaluation, 162 days left) I S
WA - X

¥ _p &) Block (i Refresh D
= ¥) Unblock =
Register or Saved : . Properties
Renew ISV Proxy | Searches~ | Renew Certificate
Create | search | Certificate Properties
[ €& = [LJ \ » Administration » Overview » Security » Certficates 52
Administration ¢ Certificates 3 items
" L St UYL ol .
: Search %| 0 Search | add Criteria ~
~ . | jprsae|
4 [ Security tlcon  lssued To Type Certificate GUID Start
PR oy ;] {EDF31980-51C8-407E-8760 1c8£} Distri {EDF319B0-51C9-407E-8760-2DABS5851CBE} 9/6/2]
0 Security Roles ]  155_SCOM_PROXY.AD.JAMFSW.CORP 1SV Proxy  GUID:daB64cas-cb50-4021-8831-2267df92030e 9/21/}
&t s 2| G TESTING.ADJAMFSW.CORP ISVProxy  GUID:aa995821-d4b6-4508-b299-fce725¢177d 9/21/|
B, Accounts
gl Certificates
37 Distribution Points
& Distribution Point Groups b

& Assets and Compliance
{5 Software Library

Ml Monitoring

], Administration

Ready

4. Inthe Register or Renew ISV Proxy dialog, select the Register certificate for a new ISV proxy option, and
browse for the ISV proxy certificate (.cer).

Register or Renew ISV Proxy

An independent Software Vendor {|5V) proxy is mstalled by an 15V and allows 15V
clients to with the Confi Manage point.

You can register a new ISV prosy by importing its certificate or by renewing the
certificate for an existing 15V proxy.

[ Select the action that you wish to perdform
& Register certfiicate for a new ISV proxy
" Renew certificate for an existing ISV proxy

—Select the 15V proy certificate that needs to be renewed
Cerificate issued to- |scCM.AD JAMFSW CORP =l

[~ Import new ISV proxy cerificate

Cerficate: | @  Browse. |

5. Click OK to close the Register or Renew ISV Proxy dialog.

6. Take note of the certificate GUID for the ISV proxy certificate. You will need to enter this when you set up
the JSS SCCM Proxy Service.



7.

8.

9.

Exporting the CA Certificate

On the Windows computer on which you plan to install the JSS SCCM Proxy Service, open Microsoft
Management Console (MMC).

Expand "Certificates (Local Computer)" and the Trusted Root Certification Authorities folder in the sidebar.
Under the Trusted Root Certification Authorities folder in the sidebar, click the Certificates folder.

In the list of certificates, double-click the CA certificate.

In the dialog that appears, click the Details tab, and then click Edit Properties.

Ensure that the CA certificate has a friendly name and click OK.

Note: Take note of the friendly name for the CA certificate. You will need to enter this when you set up
the JSS SCCM Proxy Service.

Certificate Properties ﬂﬂ

General | Cross-Certificates | OCSP | Extended Validation |

Friendly name: I

Description: I

—Certificate purposes
' Enable all purposes for this certificate
" Disable all purposes for this certificate
" Enable only the following purposes

Mote: You may only edit certificate purposes that are allowed by
the certification path.

Server Authentication
Client Authentication

1 | Bl
Add Furpose, ., |

Learn more about certificate properties

Click OK again.
Right-click the CA certificate and select All Tasks > Export.

Follow the onscreen instructions to export the certificate as a DER-encoded .cer file.
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Generating a Client Certificate for the
SCCM Plug-in

On a Windows computer that belongs to the same domain as the CA, open Microsoft Management
Console (MMCQ).

From the menu bar, choose File > Add/Remove Snap-in.

Select Certificates in the list of snap-ins and click the Add button.
x|

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ns, you can configure which extensions are enabled.

Available snap-ins: Selected snap-ins:
Snap-in ‘ Vendor ‘ = [ Consale Root Edit Extensions... |
+1'] ActiveX Control Microsoft Cor...
[Fd authorization Manager Microsoft Cor... Pamaia |
Bl Certificates Microsoft Cor...
&, Component Services Microsoft Cor... Move Up |
;&'Cnmpuh&r Managem... Microsoft Cor... =

éDEViEE Manager Microsoft Cor... [Mave Do |

=4 Disk Management Microsoft and... Add >
EEvent Viewer Microsoft Cor...
"I Folder Microsoft Cor...
|=[ Group Policy Object ... Microsoft Cor...
‘:’ Internet Information... Microsoft Cor...
[ internet Information... Microsoft Cor...

.g IP Security Monitor Microsoft Cor... Advanced
B, 1P Securitv Policy Ma... Microsoft Cor... LI vanced... |

Description:

The Certificates snap-in allows you to browse the contents of the certificate stores for yourself, a service, or a computer.

Select the My User Account option.

Click Finish, and then click OK.

The certificate is displayed below the Console Root folder in the sidebar.
Expand "Certificates - Current User" in the sidebar.

Right-click the Personal folder in the sidebar under "Certificates - Current User", and select
All Tasks > Request New Certificate.



10.

Follow the onscreen instructions and select the checkbox next to the "User" template. Then, click Enroll.

™ Certificate Enrollment o | 3]

5] Certificate Enrollment

Request Certificates

‘fou can reguest the following types of certificates. Select the certificates you want to request, and then dick Enroll.

- ' ) ) ]

[ EFs Recovery Agent 1) STATUS: Available Details (¥

I Exchange Enrolment Agent (Offine request) i) STATUS: Availsble Details ()
& More information is required to enroll for this certificate. Click here to configure settings.

I~ 3aMFUser 1) STATUS: Available Details (&
& More information is required to enroll for this certificate. Click here to configure settings,

[¥ User J) STATUS: Availsble Details (¥ —|

-

™ Show all templates
Learn more about certificates

= |[==]

The newly created certificate should appear in Personal folder in the list of certificates.

onsolel - [Console Root\Certificates - Current User\Personal\Certificates] -(O] x|
[& Fle Acon View Favorites Window Help |_515|

Y EEIEE =

| Console Root Issued To_ = [ Issued By | Expration Date | Intended Purpo: [ Actions
=] ﬁ‘ Certificates - Current User El\dmimswamr JAMF Software Certificate Authority 9/24/2013 Encrypting File & m
= [ Persanal
|| Certificates More Actions »

[ Trusted Root Certification Aut
] Enterprise Trust

(] Intermediate Certification Aut
[ Active Directory User Object
(] Trusted Publishers

[ Untrusted Certificates

(] Third-Party Root Certification
[ Trusted People

(] certificate Enrollment Reques
(| Smart Card Trusted Roots

< i mljs | |

|Personal store contains 1 certificate.

Right-click the newly created certificate and select All Tasks > Export.

Click Next to proceed.
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11.

Select the Yes, export the private key option, and then click Next.

Certificate Export Wizard

12. Select the following options:

Include all certificates in the certification path if possible
« Delete the private key if the export is successful

« Export all extended properties
Then, click Next.

Certificate Export Wizard
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13.

14.

Enter and verify a password for the certificate, and then click Next.

Complete the onscreen instructions to export the certificate as a .pfx file.

Copying the Client Certificate and CA
Certificate to the JSS Host Server

Copy the client certificate (.pfx) to the server that hosts the JSS.
It is recommended that you put the client certificate in /Library/JSS/.

Copy the CA certificate (.cer) to the server that hosts the JSS.
Itis recommended that you put the CA certificate in /Library/JSS/.

Ensure that the account used to run Tomcat has read access to both certificate files.

Setting Up the JSS SCCM Proxy Service

Note: Before completing this procedure, you may need to make a firewall exception for port 9443 on the
computer on which you plan to install the JSS SCCM Proxy Service.

On a Windows computer with Microsoft .NET Framework 4, extract the SSCM plug-in ZIP file.
Double-click the JSS SCCM Proxy Installer .msi file in the SSCM plug-in directory, and click Next to proceed.

Enter the fully qualified domain name (FQDN) for your SCCM management point, and your SCCM site
code.

e 155 SCCM Proxy Seryice Setup =

SCCM and Proxy Service Settings

- SICEM Sethbings

Managemenk Poink FODM: I

Site Code: I

= Prasy Sethings
Listening Part: |9443

< Back I Mext = I
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4. Enter the listening port number for the proxy and click Next.

5. Enterinformation about the ISV proxy certificate, server certificate, and CA certificate.
R

Certificate Settings

ISV Proxy GUID: |

ISY Prooey Friendly Mame: IJSS SCCM Proxy Certificate

Server Certificate Friendly Mame: IJS5 SCCM Proxy Certificate

A Certificate Friendly Mame: I

< Back I Mexk = I Cancel |

6. Choose where you want to install the JSS SCCM proxy service, and then click Next.

7. Click Install.

8. When the installation is complete, click Finish.

Installing the SCCM Plug-in

1. Onthe server that hosts the JSS, run the JSS SCCM Plug-in Installer JAR file.

« On OS X and Linux, execute a command similar to the following:

sudo java -jar /path/to/JSS_SCCM_PluginInstaller. jar

«  OnWindows, run Command Prompt as an administrator and execute a command similar to the
following:

java -jar /path/to/JSS_SCCM_PluginInstaller.jar

2. When prompted to restart Tomcat, type "y" to proceed.
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Configuring the SCCM Plug-in

1. Login to the JSS with a web browser.
2. Navigate to https://jss.mycompany.corp:8443/SCCMPIluginSettings.html.

3. Enter credentials for a JSS user account with API privileges to read computers and mobile devices.

SCCM Plug-in Settings

JSS Settings

J55 APl Username;
155 API Password:

Proxy Settings

Proxy URL:

CA Certificate Path:

Client Certificate Path:
Client Certificate Password:

#Enable Computer Hardware Reports

[ Enable Computer Software Reports

™ Enable Mobile Device Hardware Reparts
@ Enable Mobile Device Software Reports

Additional Settings

|| Debug Mode
#Enable Plug-in

| Reset |

Save Settings

4. Enter the URL for the proxy.

The URL must include the correct protocol and domain, and the port that you entered when you set up
the JSS SCCM Proxy Service. For example, "https://sccm.mycompany.corp:9443".

5. Enter the path to the CA certificate.
For example, "/Library/JSS/CAcertificate.cer".

6. Enter the path to the client certificate.
For example, "/Library/JSS/clientCertificate.pfx".

7. Enter the password for the client certificate.
8. Choose which inventory information you want to send to SCCM.

9. Select the Enable Plug-in checkbox, and then click Save Settings.
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Troubleshooting the SCCM Plug-in

The log for the SCCM plug-in is located in one of the following locations on the server that hosts the JSS:
= OSX:/Library/3JSS/Logs/

= Linux: /usr/local/jss/logs/

= Windows: C:\Program Files\JSS\Logs\

To enable Debug mode for the SCCM plug-in:
Log in to the JSS with a web browser.
Navigate to https://jss.mycompany.corp:8443/SCCMPluginSettings.html.

Select the Debug Mode checkbox, and then click Save Settings.

Troubleshooting the JSS SCCM Proxy
Service

The log for the JSS SCCM Proxy Service is located in C: \Program Files (x86)\JAMF Software\
JSS SCCM Proxy Service\ onthe computer with the JSS SCCM Proxy Service. This log allows you
to configure logging levels that log varying amounts of information. You can customize the amount of
information that is included in the log by choosing one of the following logging levels:

= Debug
= Info

= Warn

= Error

= Fatal

By default, the log is configured to use the “Warn” level.

For more information on the logging levels, see the following Apache Logging Services documentation:

http://logging.apache.org/log4j/1.2/apidocs/org/apache/log4j/Level.html

To configure logging for the JSS SCCM Proxy Service:

On the computer with the JSS SCCM Proxy Service, navigate to C:\Program Files (x86)\JAMF
Software\JSS SCCM Proxy Service\ andopenthe settings.xml file with a text editor.

Locate the element that begins with Level value and replace the text in quotes with either “DEBUG’,
“INFO’, “"WARN’, “ERROR’, or “FATAL".

Save and close the file.
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4.

5.

Open Services Management Console.

Right-click the JSS SCCM Proxy Service and select Restart.

Release History

Version

Changes

v2.0

Added compatibility with the JSS Conduit v2.0.
Decreased memory usage.

Added the ability to export inventory information for
secondary MAC addresses, additional disk partitions, and
logical disk sizes.

Fixed an issue that caused the SCCM plug-in to export
inaccurate data for computers that don't have unique
computer names in SCCM.

v3.0

Re-implemented the plug-in to interact with the JSS Events API,
allowing inventory information from the JSS to be updated in
SCCM in real time.

Added support for Microsoft's SCCM 2012.

Added support for communication over HTTPS.

Known Issues

The following issues are known in the SCCM plug-in v3.0:

= When you upgrade the JSS, you need to re-install the SCCM plug-in.

= Mobile device and computer names that are updated in the JSS are not updated in SCCM.

= The SCCM plug-in can be used with English and French language packs only.
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